Perfmonger をインストールしてみた

インストール

$ git clone git://github.com/hayamiz/perfmonger.git
$ cd perfmonger/
$ ./autogen.sh
$ ./configure 
$ sudo make install

使ってみる

$ perfmonger record -i 0.1                                                             
{"time": 1418432543.6794, "cpuinfo": {"nr_cpu": 4, "all": {"usr": 0.00, "nice": 0.00, "sys": 0.00, "iowait": 0.00, "irq": 0.00, "soft": 0.00, "steal": 0.00, "guest": 0.00, "idle": 0.00}, "cpus": [{"usr": 0.00, "nice": 0.00, "sys": 0.00, "iowait": 0.00, "irq": 0.00, "soft": 0.00, "steal": 0.00, "guest": 0.00, "idle": 100.00}, {"usr": 0.00, "nice": 0.00, "sys": 0.00, "iowait": 0.00, "irq": 0.00, "soft": 0.00, "steal": 0.00, "guest": 0.00, "idle": 100.00}, {"usr": 0.00, "nice": 0.00, "sys": 0.00, "iowait": 0.00, "irq": 0.00, "soft": 0.00, "steal": 0.00, "guest": 0.00, "idle": 100.00}, {"usr": 0.00, "nice": 0.00, "sys": 0.00, "iowait": 0.00, "irq": 0.00, "soft": 0.00, "steal": 0.00, "guest": 0.00, "idle": 100.00}]}, "ioinfo": {"devices": ["sda", "dm-0", "dm-1", "dm-2", "dm-3"], "sda": {"riops": 0.0000, "wiops": 0.0000, "rsecps": 0.0000, "wsecps": 0.0000, "r_await": 0.0000, "w_await": 0.0000, "avgrq-sz": 0.0000, "avgqu-sz": 0.0000}, "dm-0": {"riops": 0.0000, "wiops": 0.0000, "rsecps": 0.0000, "wsecps": 0.0000, "r_await": 0.0000, "w_await": 0.0000, "avgrq-sz": 0.0000, "avgqu-sz": 0.0000}, "dm-1": {"riops": 0.0000, "wiops": 0.0000, "rsecps": 0.0000, "wsecps": 0.0000, "r_await": 0.0000, "w_await": 0.0000, "avgrq-sz": 0.0000, "avgqu-sz": 0.0000}, "dm-2": {"riops": 0.0000, "wiops": 0.0000, "rsecps": 0.0000, "wsecps": 0.0000, "r_await": 0.0000, "w_await": 0.0000, "avgrq-sz": 0.0000, "avgqu-sz": 0.0000}, "dm-3": {"riops": 0.0000, "wiops": 0.0000, "rsecps": 0.0000, "wsecps": 0.0000, "r_await": 0.0000, "w_await": 0.0000, "avgrq-sz": 0.0000, "avgqu-sz": 0.0000}, "total": {"riops": 0.0000, "wiops": 0.0000, "rsecps": 0.0000, "wsecps": 0.0000, "r_await": 0.0000, "w_await": 0.0000}}}